Blender Builds

MiikaHweb provides OpenMP and CUDA enabled Windows builds of Blender development versions.

There are two different builds available: a 64-bit build for modern systems and a 32-bit build for older systems.

General notes

  • Compiled using Visual Studio 2013
  • Builds include CUDA binaries for all officially supported devices
  • Uses OpenMP to allow simulation multithreading
  • Compressed using 7-zip format to minimize download size

Git

Latest Git "master" commit: Revision 9e929c9 by Brecht Van Lommel 1 h ago.

Downloads

Windows Blender 2.71.6 Master (32-bit + 64-bit)
Date: Sep-17-2014
Blender Git Master

This is the Git Master version of Blender that is used in new releases. Compiled with OpenMP, OSL and CUDA.

Next release development targets

Blender Git "master" commit log







(Comments, questions or discussion about these builds or Blender in general.)

francois
Sep-14-2009 22:32
please, could you share your config file for compiling 2.5.
I'm looking for the best setting file for my config :

-Intel Core 2 Quad CPU Q6600 @2.4 GHz; 8 MB L2 cache (http://www.intel.com/products/processor/core2quad/index.htm)
-Vista 32bits
-4gb ram
-Nvidia Geforce 9800 GX2

I'm sorry if it bother you, it's really hard to find good and easy information about that.

thx

MiikaH
Sep-15-2009 11:56
Hi,

What config file are you talking about? All important optimization flags are listed in the build info.

Your CPU doesn't support SSE4.1 but you can use SSE2 builds. (The additional performance in a special SSE3 build is insignificant.)
francois
Sep-15-2009 17:27
I was talking about user-config.py, aren't you using one ?

I don't really understand the flags though, not sure what every one does, but for sure I'd like to compile the best optimized build with openMP enable and LargeAddressAware if possible

thank you
MiikaH
Sep-15-2009 17:48
Here is a slightly modified version of the user-config I'm using for SSE4.1 builds:
http://www.miikahweb.com/other/user-config_highopti.py

I think you can just remove the SSE4 flag. About LAA, I'm not sure whether it works that way or not. (It's not stated in build description so... ;p)
francois
Sep-15-2009 18:46
Hey thx man that's really nice of you !
this is the error I got :

scons: Building targets ...
Compiling ==> 'AUD_Buffer.cpp'
cc1plus.exe: error: invalid option `ssse3'
cc1plus.exe: error: unrecognized command line option "-fopenmp"
cc1plus.exe: error: unrecognized command line option "-fopenmp"
cc1plus.exe: error: unrecognized command line option "-fopenmp"
intern\audaspace\intern\AUD_Buffer.cpp:1: error: bad value (core2) for -march= switch
intern\audaspace\intern\AUD_Buffer.cpp:1: error: bad value (core2) for -mtune= switch
scons: *** [C:\blender\build\win32-mingw\intern\audaspace\intern\AUD_Buffer.o] Error 1
scons: building terminated because of errors.


MiikaH
Sep-15-2009 20:02
OpenMP is only supported in GCC 4.2 or later. Same thing with ssse3 and core2 settings.

You can download a MinGW that uses the newest GCC (4.4.1) here:
http://www.tdragon.net/recentgcc/
(Bundled Installer)

You might have to reinstall SCONS to use this new MinGW. However, compiling with older GCC 3.x should work without OpenMP, ssse3 and using -march/tune=generic instead of core2.
francois
Sep-15-2009 22:14
ok see, now YOU made my day !!! THANK YOU SO MUCH !
even I still don't understand all the flag though. it compile fine.
That's too bad we don't find too much information about that on the wiki.
You seem to manage this thing, you should write a doc for it on the wiki, I'm sure there is a lot of guy in my situation looking for more information about scons without having to read the doc, because I tried and when you don't know what you are looking for that kind of hard, plus knowing the difference between ccflag and cfflag, and which one goes with which O_O

anyway that was really nice though !

Thanks again
francois
Dec-21-2009 10:28
hi,
I've been trying to use those settings with blender 2.5 now, but I got error every time.
it is based on what you gave me before.
http://www.pasteall.org/9943/python
there is probably something there I shouldn't use anymore, but can't figure what :(, do you have any idea ?
francois
Dec-21-2009 11:05
it doesn't seems to like this line :

LLIBS = ['-lgomp', '-lpthread']
Juang3d
Dec-28-2009 22:49
Do you have an X64 build for SSE 4.2?

Cheers.
MiikaH
Dec-29-2009 08:36
Sorry but SSE4 isn't possible with VC++ compiler and that's the only 64-bit one I have.
Steve Boyer
May-01-2010 17:50
Hi Miika,

When I try to set my domain cube to volume to get a smoke render using your recent Win-32 builds, Blender crashes.

Not so with the 27226 build from Blender.org.

Confirm?
MiikaH
May-01-2010 17:56
Recently I started to have similiar issues too. Crashing when rendering. I believe it's a bug in current SVN.

However it doesn't crash if I set rendering "Display" to be "Image Editor" instead of default "Full Screen". Try if that works for you too.
Steve Boyer
May-01-2010 18:03
Still crashes, without rendering.

Just assigning the volume material crashes out Blender.

Wire, Halo, and Surface material types are ok -- just not Volume.
MiikaH
May-01-2010 18:11
In that case, no issues here. Changing material settings works perfectly. So can't help you.

But if you already haven't tried, you can try another build (sse2,sse4,x64). And also try extracting these builds to a new directory. (In case you extracted it over another build. Because old settings etc. can cause issues.)
Juang3d
Jul-26-2010 17:03
Hi Miikah, thanks for your build, now i understand pretty well why you cannot compile an X64 version of blender with sse4.2.

Actually i'm trying to compile myself with MinGW, i succeed, but you have a lot more performance than me when it is about smoke simulation.

Can you share your way of compiling blender? i've tried also MSVC Exoress 2008, but i don't get your results, can you explain a bit more (not a complete tutorial, only the key things, no matter if it's with MinGW (now i'm trying to compile with the compiler you posted, TDM-GCC and with your user-config.py but i don't get your results, instead i get the error 0xc00000005 everytime i try to run blender.exe)

Thanks for your help, compiling blender is great and very exciting for me :)

Cheers.
MiikaH
Jul-26-2010 17:15
@Juang3d

There is really nothing to share with my settings. I'm currently compiling with MSVS 2008 using default settings. You should note that MSVC Express doesn't support OpenMP so that's most likely the reason your build is slower.

And about MinGW builds: I don't do those anymore because MinGW always had strange errors, especially when updating MinGW / GCC version. That error you mentioned appeared after GCC 4.5.0. Yet it was actually slower than Visual C++.
Juang3d
Jul-26-2010 17:36
So it's better to build with MSVC 2008 than with MinGW in the latest version?

Ok, i'll try, do you use CMake? and do you use some optimization settings like large addres or something?

I tried to use optimizations with CMake, but i'm not sure where to put it (also cpu optimizations like match:core2 and such things) maybe is not possible or is not needed, thanks for your help, i'm new to this :)

Also thanks for working in one of the most needed features of blender fluid simulations, wetmaps! knowing that you are working on this are great news!!

Thanks!

Cheers.
MiikaH
Jul-26-2010 17:52
"So it's better to build with MSVC 2008 than with MinGW in the latest version?"

If you have other VC than the limited "express" one then it's faster.

However, you can always try earlier MinGW version (GCC 4.4) from TDM: http://sourceforge.net/downloads/tdm-gcc/
It should work without that "0xc00000005" error. :)
Juang3d
Jul-27-2010 20:15
I had no luck with the GCC 4.4 compilation, i'm not able to make tdm-gcc 4.4.1 working i don't know why, but i have a MSVC Express 2008 working perfectly, it's a shame that it does not support x64 or OpenMP :p and it's too expensive to acquire a license only for that (800€), so i'll stick with this until GCC 4.5 is working, i hope it's soon.

Cheers and thanks for your help :)
MiikaH
Aug-01-2010 20:02
Juang3d: I have already forwarded your report to Genscher and it will be fixed when it will be. I don't know how to fix it.

And I hid your comment because this isn't right place to report bugs. Use email next time.
Juang3d
Aug-01-2010 20:06
Ok, sorry for the inconvenience.

Where should i post bugs, so i can post by myself?

Thanks for reporting it.

Cheers.


MiikaH
Aug-01-2010 20:12
Juang3d:
The official way to report bugs is Blender Bug Tracker: http://projects.blender.org/tracker/index.php?group_id=9.

But don't expect it to be fast. :p
Juang3d
Aug-01-2010 20:32
One more time, thanks.

It seems that there is a bigger bug there, the material editor is not working for me, no matters if it's a MinGW build or a MSVC build.

I'll wait until this is solved :)

Cheers.
Juang3d
Aug-01-2010 20:59
I was lucky, thanks for reporting the bug, it's already solved in revision 30948 :D

I'm happy!!!

Cheers.
Dennis F.
Sep-08-2010 10:06
Hey Miikah,

1st of all if have to say THANK YOU!
Your builds are GREAT and you works are pretty amazing!
I tryed your fire-tutorial and its realy great! Works also fine with your "turbolence"-mod.
I´d like too see an atomic-bomb tutorial from you.
With preasure wave :)
Licuadora
Sep-22-2010 02:00
StarStarStarStarDark Star
Hello Mr. MiikaH.
Do you have a Linux version?
I am no good compiling, can you do a tutorial about that?
All I want is to test the new SmallLuxGPU from LuxRay.
And it would be cool to have it optimized for my CPU or system overall.
Evan J
Sep-22-2010 21:23
Hello I was interested in your smoke patch Andrew refers to yours as being a good one. I just have not been able to find it. I bet you have already created something new to take it's place. Can you point me in the right direction?

Thanks

Evan
MiikaH
Sep-22-2010 21:45
@Evan J

My smoke patch is already in Blender trunk SVN. So you don't need a patch anymore, just get a recent build.
Mike Wedding Band
Sep-23-2010 13:54
Hi MiikaH,

I have to say, Dynamic Paint looks awesome. I run a wedding band mostly, but I've been dabbling in blender and doing live videos for my originals band... Anyway, I digress...

I was wondering the same as the fellow above, about whether there's a build for linux available of your dynamic paint. I completely love the idea, and really hope this patch gets adopted into the trunk!

Cheers,

Mike
MiikaH
Sep-23-2010 16:18
There seems to be one 64-bit Linux build on GraphicAll.org. But because I rarely use Linux, I'm not gonna build those myself.
PerfectionCat
Sep-28-2010 01:04
Hello.
I am embarrassed because it doesn't take the following error though it tries to mount your made DynamicPaint.
Thank you very much if there is advice.
It questions with the translation software because English is inexperienced and pardon here, please.

MY Environment:
WindowsXP SP3
VisualC++2008ExpressEdition
Blender Source (Base):2.54b Release Source
2010-09-27 SVN Download
-->Error Message
rna_rna.lib(rna_object_gen.obj) : error LNK2001: "_RNA_DynamicPaintCanvasSettings"
rna_rna.lib(rna_modifier_gen.obj) : error LNK2001: "_RNA_DynamicPaintCanvasSettings"
rna_rna.lib(rna_modifier_gen.obj) : error LNK2001: "_RNA_DynamicPaintPainterSettings"
..\..\..\install\msvc_9\blender.exe : fatal error LNK1120:
PerfectionCat
Sep-28-2010 04:07
I'm sorry.
It was possible to solve it for myself.
It did because of the thing that rna_dynamicpaint_gen.c generated with RNA was not added to the project.
It fired.
PerfectionCat
Sep-29-2010 06:31
Hello.
DynamicPaint can be mounted, and it tries variously.
It uses it can the color be moved from Canvas to Canvas though it thought?
For instance, the handkerchief becomes dirty when wiping it with the handkerchief in mud as for the dirty face.
PerfectionCat
Oct-22-2010 01:47
The icon registration of Modifier window has come off.
George
Nov-09-2010 14:19
Hi, I'm trying to apply your 1.08 patch to trunk r32964, but since I have never applied a patch before I might be doing something wrong: the build fails because of these 4 errors:

bf_editor_physics.lib(physics_ops.obj) : error LNK2019: unresolved external symbol _DPAINT_OT_bake referenced in function _operatortypes_dynamicpaint
bf_modifiers.lib(MOD_util.obj) : error LNK2001: unresolved external symbol _modifierType_DynamicPaint
bf_rna.lib(rna_modifier_gen.obj) : error LNK2019: unresolved external symbol _dynamicPaint_Modifier_createType referenced in function _rna_DynamicPaint_set_type
bf_rna.lib(rna_modifier_gen.obj) : error LNK2019: unresolved external symbol _dynamicPaint_Modifier_free referenced in function _rna_DynamicPaint_set_type

(I'm using CMake with options: Buildinfo,FFMpeg,Install,MOD_Boolean,MOD_Decimate,MOD_Fluid,OpenMP,Python,Python_Install,RayOptimization)

Could you please give me a hint ?
Tom
Dec-09-2010 08:07
Could you tell me if I have to compile the Blender on my own to utilise milticore? I've downloaded an openmp svn version from graphicall several times, but it always uses only one core (have Quad Core). What should I do to enable openmp?
MiikaH
Dec-09-2010 08:11
@Tom

It depends on what you are doing. Only some parts of Blender can utilize multiple cores, so even with OpenMP enabled build there are many tasks that simply use one core.

Things like smoke or dynamic paint can use multicores (through OpenMP) quite well, but you still shouldn't expect 100% CPU usage. :p
Tom
Dec-09-2010 08:30
I've tried smoke sim, particle system and cloth sim. All of them used max 25% of my processor power. Thanks for quick response :)
BlenderManiac
Dec-29-2010 18:10
Hi MikaH Thanks for your patch and work. Im noob in building and patching blender. So i patched copy of my blender svn with Tortoise svn and hi fetching some files to previous revision, so question can i update that patched copy with svn? Regards and Happy New Year
Guido
Jan-20-2011 04:04
Hi MikaH i love your dynamic paint. is there any way to get a new OSX 64bit build
or instructions on how to add dynamic paint code to a new builds for mac thank you son much.
tkroo
Jan-27-2011 05:29
Guido, I posted an OSX 64 bit build here: http://graphicall.org/builds/builds/showbuild.php?action=show&id=1695

MiikaH, thanks for this wonderful patch!
designeran
Feb-14-2011 13:52
simplemente gracias por el aporte!!!
Finnish Esa Mäkelä
Feb-16-2011 13:25
StarStarStarStarStar
Ihan kiva blogi on sulla tässä, sisältö tietysti mielenkiintoisin ja paras asia. =D Itsekkin olen Blenderiä ruvennut harjoittelemaan ja tehnytkin pari käyttökelpoista luomusta jo. :D Mites näin muuten, mistä päin Suomen maata ymsyms? (: Vastaa vaikka tonne mun blogii mikä on tos kotisivutilas - johonki vaa ni nään sit helposti (: Keep on the good work!
Aake
Mar-25-2011 07:40
Morot MiikaH

I have compilen Wine in Ubuntu 10.10 - both 32 ja 64-bit.
Then i try to run blender in there.
Some serious problem with VC2008 runtime librarys.
Any idea to void these libraries.
I'am running rendering farm and window$ blender is only way.
Another problem is MESA errors. Blender loads some OpenGL code: blender -b scene.blend ... ... gives error about Mesa drivers.
Is it possible to compile blender totaly without GUI ???

Best regards

Aake / Finland

Eonmach R
Apr-23-2011 02:33
thanks for the builds, your dynamic paint patch is out of this world, really, hope to see it in the trunk, but if not, I always will come back and seek for your awesome builds...

thanks for your development.

TheElwolf
May-02-2011 20:04
Hi. This Dynamic Paint tool seem awesome. But alas I cant use it because it's only on Windows. Is it possible for you to build a blender 2.57b with both Dynamic Paint and Bmesh ? (Bmesh is already available for mac though) By the way is your vertex group painting tests going well enough for us to see it implemented in your Dynamic P tool anytime soon?

Thanks for all the time you're inversing on this ...and other projects -iWave- :)
Oscar Rodriguez
Aug-02-2011 21:22
Para cuando dynamic paint para osx?

Saludos desde Mexico
Germanny
Nov-15-2011 17:44
Thanks for your outstanding work!
BTW: Cycles r41844 did not work w. my Nvidia 9800GT + GPU,Cuda or OpenCL.

Best wishes,
G.
MiikaH
Nov-15-2011 18:01
@Germanny

Blender officially supports GPUs with "compute capability" 1.3 or higher. (Atm. 1.3, 2.0 and 2.1)
http://developer.nvidia.com/cuda-gpus
Your card has 1.0. :p

It would be possible to enable CUDA for lower versions on my builds but that'd be slow and have some features disabled.
Germanny
Nov-15-2011 20:39
@Miika
Thx for the info!
Sad for me :/


Jesus
Apr-19-2012 22:58
It seems the link is broken for Trunk win 31 & 64.
Server not Found :(
Pyroevil
Apr-30-2012 15:35
StarStarStarStarStar
I test Particles Nodes build !\nReally interesting ! Hope to see good progress with new nodes. Thanks for this build Mikaah !\n\nHere is simples tests I did :\n\nhttp://blenderartists.org/forum/showthread.php?253332-My-first-Particles-Nodes-test
aneyevuproduction
May-19-2012 16:02
Hia are these builds built with jemalloc
and would these builds utilize my 16gb ram
as well as the rest of my settup which
AMD 1055t x6
AMD radeon 6950 2gb
syed
May-27-2012 19:24
Miika..i saw your demo video on youtube, those were just amazing...keep up good work..
eon
Jun-01-2012 06:06
Hi, awesome stuff, but your last few 32bit builds lack the full screen button on top!!!

mike
Oct-15-2012 20:46
yo miika you seam to know about this stuff, if i have alot of builds in different places (downloads and program 86 folders)is that a problem.im running windows7 pro, i7,amd5450. 64 bit.
Larry Phillips
Oct-27-2012 23:31
Hey Miika I like your builds and they are often newer release than available at buildbot.

But there is a frequent issue with your win32 download that has been occurring the past few weeks. Today (r51691 win32) is the same issue again... can't download. The download page says "Error! Invalid file".

Thanks.
-LP
MiikaH
Oct-27-2012 23:56
@Larry:
Thanks for reporting the issue. It should work now. :)
mike
Nov-09-2012 03:07
just ran across a new to me script. it makes models that you make and makes them addons. so u can simply select it in the add mesh list. no more having to go to another blend file or if you have a specific library for objects. just one click and its there. its called "creaprim.py" its great. you even have to enable it in preferences.ha absolutly amazing. the blender community is is ,im at a loss for words. wow .sorry dont have a link for it right now when i get it i'll post it.
Nicolai
Dec-19-2012 14:11
Agony. Despair. Fetal position.
So I used that latest build, but I got still no "Use object material". I managed to move one object over another, paint is running down, but blurry. Like the canvas is a paper tissue. I tried vertex coloring on an insanly subdivided canvas, I tried baking to an image sequence.
Still no wet painting running down the canvas. I had the idea to use the glossy material of my brush, but can't find that button. I followed your guides and bazillions of tutorials, but no cookie. What am I doing wrong?
Todd McIntosh
Dec-21-2012 13:51
Hi Miika, love the new results from the latest round of smoke sime work that you did!

I'm trying to figure a way to bake a smoke sim and then use it multiple times via instancing. This seems to work in the viewport, but in the render, only the original sim in the original location renders. Is there any way to accomplish this?

The scene I'm trying to attempt is a hall full of burning torches. It would be so helpful if I only had to sim one torch and then instance the rest of them from the same bake files. Any ideas?

Thanks.
adrian
Dec-24-2012 15:15
i installed Blender 2.65.3 Trunk 32-bit and it is lag .can you help me to my problem
jasonhan
Jan-07-2013 20:56
I tried launching 2.65.5 Windows 64-bit build on my 4-core and it gives a "Application has failed to start because its side-by-side configuration is incorrect." error.nWhat does this mean. On the other hand, I loaded the 2.65.5 Windows 64-bit on my laptop which is less powerful and works just fine. Please help. I need to get it to work on the 4-core desktop. Thanks. My email address is: jason.c.w.han@gmail.com
MohamedSakr
Feb-12-2013 07:21
@jasonhan:download this and it should work http://www.microsoft.com/en-us/download/details.aspx?id=2092nn@Miikah:Please contact me as I want to do development to Blender smoke/fluid simulator using OpenCL(I got already ideas but need to know more about the algorithm of the simulator)nncontact me on gmail please : 3dsakr@gmail.comn
Juergen
Mar-20-2013 13:57
Hi Miika,

you inspired me to try building blender myself. I still use VC++ 2008 but I'd like to try building blender with VS 2012 express (as it supports OpenMP and has this nice auto vectorizing thingy). Unfortunately I have problems compiling the 3rd party prerequisites like OpenimageIO etc. do you know of any documentaion on this?
mike kelly
Mar-24-2013 05:56
could you please put the newest questions on top. Im reeeeaally gettin bored with having to scroll down to see if there's a reply to a question i've psted. not that there's ever an one.guess im not from the right country. been coming to this site for a while never a responce. ow well . happy blending
mike kelly
Mar-24-2013 06:00
im mean come on you have a question from 2009 up there
ymtaufik
Apr-08-2013 01:00
Hi Mika, could you help for old card (cuda version sm_12), win 32 ?.

thanks in advance
earthdesign
Apr-30-2013 15:31
Hi, I downloaded the Blender 2.66.6 Windows 32 bit version, but it does not support CUDA cc 1.2, is there any other problem
MiikaH
Apr-30-2013 18:44
@earthdesign Hey, I don't have a 1.2 GPU to test with but the build archive seems to contain all CUDA binaries. Have you tried to update latest drivers from nvidia website?
earthdesign
May-01-2013 03:12
Hi, I have the latest drivers, so if its not a bug then I guess I have to upgrade my Graphics card, thanks anyways and cheers
Steve
Nov-01-2013 21:54
Hi Mika, SSS will suport GPU?
Germannny
Nov-23-2013 15:14
Hi, have you stopped releasing new builds?
(Oct.29 - Nov.23,2013)
Or is there an error on your site?
Keep up the good work, thx!
Belich
Feb-16-2015 03:39
Hello i just have a doubd about the sub-step property of the canvas on the dynamic paint. nThat sub step on the canvas, does only affects the moving brush? nI mean i have a rotating canvas and it doesn't do anything.nI assume that it was a design thing thats why i didnt report as a bug, but a i want to be sure. nCheers

Write a comment:
Name: *
Site:
Language:
Review:
Verification Code: *verification image (?)
Message: *
By: Miika HmlinenLast update: Nov-07-2014 14:18 MiikaHweb | 2003-2017