Blender Git Commits

Blender Git "master" branch commits.

Revision 4f4a484 by Luca Rood
1 hour 17 min ago
Cloth refactor: Remove goal springs and some other cleanup

This removes the goal springs, in favor of simply calculating the goal forces on the vertices directly. The vertices already store all the necessary data for the goal forces, thus the springs were redundant, and just defined both ends as being the same vertex.

The main advantage of removing the goal springs, is an increase in flexibility, allowing us to much more nicely do some neat dynamic stuff with the goals/pins, such as animated vertex weights. But this also has the advantage of simpler code, and a slightly reduced memory footprint.

This also removes the `f`, `dfdx` and `dfdv` fields from the `ClothSpring` struct, as that data is only used by the solver, and is re-computed on each step, and thus does not need to be stored throughout the simulation.

Reviewers: sergey

Reviewed By: sergey

Tags: #physics

Differential Revision:
Revision 4d82d52 by Mai Lavelle
3 hours 55 min ago
Cycles: Fix building for some compilers
4 hours 4 min ago
Cleanup: remove redundant temp dir init

This is already called by wm_init_userdef, in old code
different initialization methods were used but now it's not needed.

Confusing since prefs are loaded in this function that don't initialize temp.
8 hours 27 min ago
Cleanup: minor wm_homefile_read simplification

Logic in this function is a bit scattered,
minor changes to avoid confusion.

Also rename 'from_memory' to 'use_factory_settings'.
Revision 762319e by Mike Erwin
11 hours 43 min ago
fix redundant assignment

Thanks clang for the warning.
12 hours 36 min ago
Cleanup: remove BLI_getlastdir

Replace with BLI_path_name_at_index
13 hours 15 min ago
Pydoc: Change Wikipedia links and grammar in mathutils matrix code
13 hours 27 min ago
Cleanup/optimization: Simplify some usages of uiItemFullO/_ptr, avoid multiple search of same op.
13 hours 45 min ago
Cleanup: ignore open-blend as startup/prefs basis

No reason startup/prefs would ever be blend-file relative.
18 hours 25 min ago
Depsgraph: Fix missing relations update tag when typing #frame

New depsgraph requires relations to be updated after drivers changes.
20 hours 42 min ago
Cycles: fixed warnings
21 hours 4 min ago
Fix T51024: Switch install_deps to set OSL_ROOT_DIR instead of CYCLES_OSL.

Path by @alekulyn, thanks.

Differential Revision:
21 hours 32 min ago
Fix/workaround T50533: Transparency shader doesn't cast shadows with curve segments

There seems to be a compiler bug of MSVC2013. The issue does not happen on Linux and
does not happen on Windows when building with MSVC2015.

Since it's reallly a pain to debug release builds with MSVC2013 the AVX2 optimization
is disabled for curve sergemnts for this compiler.
23 hours 9 min ago
Create correct node after image file drag&drop for Blender Render
23 hours 35 min ago
BLI_path_util: add BLI_path_name_at_index

Utility to get a file/dir in the path by index,
supporting negative indices to start from the end of the path.

Without this it wasn't straightforward to get
the a files parent directory name from a filepath.
1 day and 5 hours ago
Fix for splash not opening centered

When the new window didn't end up using the size stored in the preferences
the splash would not be centered (even outside the screen in some cases).

Now centered popups listen for window resizing.
1 day and 21 hours ago
Cycles: Use more friendly GPU device name for AMD cards

For example, for RX480 you'll no longer see "Ellesmere" but will see
"AMD Radeon RX 480 Graphics" which makes more sense and allows to easily
distinguish which exact card it is when having multiple different cards
of Ellesmere codenames (i.e. RX480 and WX7100) in the same machine.
1 day and 21 hours ago
Cycles: Cleanup, add some utility functions to shorten access to low level API

Should be no functional changes.
1 day and 21 hours ago
Update CLEW to latest version

Needed to get access to some AMD extensions.
1 day and 21 hours ago
Cycles: Simplify some extra OpenCL query code
By: Miika HämäläinenLast update: Nov-07-2014 14:18 MiikaHweb | 2003-2017