Blender Git Loki

Blender Git "temp_bmesh_multires" branch commits.

Page: 15 / 21

November 7, 2020, 10:53 (GMT)
VSE: Don't store proxy images in cache

Proxies are expected to be fast to read. Storing them in cache has
little to no effect on performance.

This change also allows to omit invalidation of cache when user switch
between proxies and original media.

Reviewed By: sergey

Differential Revision: https://developer.blender.org/D9473
November 7, 2020, 10:53 (GMT)
Add background rectangle option to video sequencer Text strip

This adds a Box option to the Text strip's style properties, plus related Box Margin value:

{F9208309}

When enabled the text is placed on top of a solid-filled rectangle of a chosen color, as shown below:

{F9208324}

When the box option is disabled the text strip works the same as it does now. When the box option is enabled the meaning of the Shadow option changes to provide a drop-shadow on the rectangle (and not on the text itself). The latter made more sense to me.

The box margin is specified as a fraction of the image width. The offset of the drop-down box shadow is fixed to a specific fraction of the image width as well.

I tested this feature on a movie of a couple of minutes containing dozens of text strips (all with box background), edge cases like multi-line strings and text overlapping the image edges.

Reviewed By: ISS

Differential Revision: https://developer.blender.org/D9468
November 7, 2020, 10:53 (GMT)
Refactor: move Scene .blend expand to IDTypeInfo callback
November 7, 2020, 10:53 (GMT)
Refactor: move Scene .blend lib reading to IDTypeInfo callback
November 7, 2020, 10:53 (GMT)
Cleanup: rename time related variables

Variables renaned:
- cfra -> timeline_frame
- nr -> frame index
- cfra_over -> overlap_frame

Function seq_give_stripelem_index was renamed to seq_give_frame_index.
November 7, 2020, 10:53 (GMT)
Blenloader: access report list via api
November 7, 2020, 10:53 (GMT)
Blenloader: expose BLO_reportf_wrap in api

This function is used by a couple of functions that are moved out of blenloader.
November 7, 2020, 10:53 (GMT)
Refactor: move Scene .blend data reading to IDTypeInfo callback
November 7, 2020, 10:53 (GMT)
Refactor: move Scene .blend writing to IDTypeInfo callback
November 7, 2020, 10:53 (GMT)
CMake: Fix wrong library used for dependency

Was causing compilation failure on fresh builds.
November 7, 2020, 10:53 (GMT)
Refactor: move PointCache .blend I/O to blenkernel

Ref T76372.
November 7, 2020, 10:53 (GMT)
Cleanup: Fluid engine API return types

Use bool return type where possible instead of int (the return values from fluid object are already boolean instead of int).

Also removed several if guards in API functions. If one of the arguments is in fact invalid / nullptr (should not happen though), it better to catch them directly where they failed and not silently escape them.
November 7, 2020, 10:53 (GMT)
Cleanup: Clang-Tidy, modernize-use-bool-literals
November 7, 2020, 10:53 (GMT)
Refactor: move sequencer modifier .blend I/O to sequencer module

Ref T76372.
November 7, 2020, 10:53 (GMT)
Cleanup: Alembic, simplify expression

Change `1 + current_mat++` to `++current_mat`.

No functional changes.
November 7, 2020, 10:53 (GMT)
Refactor: move Paint lib linking to blenkernel

Ref T76372.
November 7, 2020, 10:53 (GMT)
Refactor: move color settings .blend I/O to blenkernel

Ref T76372.
November 7, 2020, 10:53 (GMT)
Cleanup: Clang-Tidy, modernize-use-emplace
November 7, 2020, 10:53 (GMT)
Fix compilation error of bf_draw

Similar to previous commit, missing build dependency.
November 7, 2020, 10:53 (GMT)
Cleanup: Alembic, simplify material assignment code

Refactor material assignment code such that:
- `build_mat_map()` just returns the built map (instead of relying on
modifying a map passed as parameter),
- `LISTBASE_FOREACH` is used to loop over a `ListBase` (instead of a
hand-crafted for-loop),
- just `return` when not enough material slots can be created (instead
of setting a boolean to false, then doing some useless work, then
checking the boolean),
- reorder some code for clarity, and
- rename `mat_map` to `matname_to_material` so that the semantics are
clearer.

No functional changes.
Tehnyt: Miika HämäläinenViimeksi päivitetty: 07.11.2014 14:18MiikaH:n Sivut a.k.a. MiikaHweb | 2003-2021