english Sivu saatavilla vain englanninkielisenä.

Blender Git Statistics -> Branches -> temp-ui-button-type-refactor

"Temp-ui-button-type-refactor" branch

Total commits : 12
Total committers : 1
First Commit : May 2, 2020
Latest Commit : August 7, 2020


Commits by Month

DateNumber of Commits
August, 20201
July, 20203
June, 20206
May, 20202

Committers

AuthorNumber of Commits
Julian Eisel12

Popular Files

FilenameTotal Edits
interface.c8
interface_intern.h7
interface_handlers.c6
UI_interface.h4
interface_region_search.c4
interface_templates.c3
interface_widgets.c3
interface_layout.c2
interface_ops.c2
interface_context_menu.c2

Latest commits Feed

August 7, 2020, 11:04 (GMT)
Merge branch 'master' into temp-ui-button-type-refactor
July 3, 2020, 16:47 (GMT)
Add own button type for color buttons, don't using uiBut.a1/.a2 for them
July 3, 2020, 14:31 (GMT)
Add own button type for progress-bar, don't using uiBut.a1 for progress
July 3, 2020, 13:41 (GMT)
Merge branch 'master' into temp-ui-button-type-refactor
June 7, 2020, 21:45 (GMT)
Fix missing NULL checks for buttons without layout
June 7, 2020, 21:29 (GMT)
Merge branch 'master' into temp-ui-button-type-refactor
June 7, 2020, 21:27 (GMT)
Store search item in search-button data, don't reuse general void pointer

Rather than re-using the `uiBut.func_arg2` pointer to reference the active
search item, have an own pointer for that in `uiButSearch`.

Unfortunately, we still need to pass the reference as `arg2` to the
`uiBut.func` callback. But we don't need to keep `uiBut.func_arg2` set the
entire time for that.
June 5, 2020, 12:18 (GMT)
Remove unnecessary `uiButSearchData` struct

This doesn't add anything useful if we already have a struct for search
buttons. At the very least it should not be allocated.

Also uses clearer names for `uiButSearch` members.
June 5, 2020, 11:54 (GMT)
Fixes for changes in master
June 5, 2020, 11:54 (GMT)
Merge branch 'master' into temp-ui-cleanup
May 3, 2020, 20:59 (GMT)
UI Code Quality: Use derived structs for search buttons and decorators

The current on-size-fits-all `uiBut` creates quite a mess, where it's hard to
reason about which members are free for use, under which conditions they are
used and how. This tries to untangle that mess.
A draw-back is that many casts have to be done although this seems reasonable.

(I don't expect an in-depth review, but would like to have the general design
change reviewed first.)

A complication was that we sometimes change the button type after it's created.
So I had to add logic to reallocate the button for use with the new, possibly
derived struct. Ideally that wouldn't be needed, but for now that's what we have.
This is also something I'd like to have reviewed.

Differential Revision: https://developer.blender.org/D7610
May 2, 2020, 00:06 (GMT)
Add own derived struct for search buttons

A complication was that we sometimes change the button type after it's created.
So I had to add logic to reallocate the button if needed, so the derived data
can be used.

MiikaHweb - Blender Git Statistics v1.06
Tehnyt: Miika HämäläinenViimeksi p?ivitetty: 07.11.2014 14:18 MiikaH:n Sivut a.k.a. MiikaHweb | 2003-2020