english Sivu saatavilla vain englanninkielisenä.

Blender Git Statistics -> Developers -> billreynish

William Reynish (billreynish)

Total Commits : 486
Master Commits : 390
Branch Commits : 96
First Commit : December 6, 2018
Latest Commit : March 26, 2021

Commits by Month

DateNumber of Commits
March, 20213
February, 20210
January, 20215
December, 20200
November, 20200
October, 20200
September, 20200
August, 20200
July, 20200
June, 20200
May, 20201
April, 202066
March, 202010
February, 202018
January, 202031
December, 201915
November, 20192
October, 20193
September, 201932
August, 201917
July, 201910
June, 201941
May, 201996
April, 201920
March, 201981
February, 201923
January, 20194
December, 20188

Commit Distribution

PathNumber of Commits
master390
modifier-panels-ui47
temp-checkbox-layout-tweaks24
filebrowser_redesign13
userpref_redesign8
temp-lanpr-cleanup26
temp-lanpr-cleanup6
vr_scene_inspection3
temp-cmake-without-sorted-libs3
temp-blender-2.81-release-with-wrong-merge2
temp-lanpr-staging2
asset-system-filelist1
temp-keymap-industry-compat1
asset-browser-poselib1
ui-asset-view-template1
asset-browser1
temp-pose-flipping-fix-attempt1

Favourite Files

FilenameTotal Edits
industry_compatible_data.py98
space_view3d.py49
space_sequencer.py44
blender_default.py32
space_view3d_toolbar.py27
space_toolsystem_toolbar.py26
rna_scene.c20
rna_space.c19
CMakeLists.txt17
UI_icons.h16

File Changes

ActionTotalPer Commit
Added2590.5
Modified2 4205.0
Deleted160.0

Code Changes

ActionTotalPer Commit
Lines Added10 74122.7
Lines Removed8 02816.9

Latest commits Feed

Revision dcd90bf by William Reynish / Hans Goudey (master)
March 26, 2021, 16:21 (GMT)
UI: Remove "Enable physics for:" text in physics properties

The "Enable physics for:" text makes no semantic sense- i.e.
"Enable physics for Fluid". Additionally, the leading text is just not
necessary, this section is just as clear without it.

Differential Revision: https://developer.blender.org/D10537
March 3, 2021, 17:15 (GMT)
UI: Clean up labels and descriptions: "Draw" to "Display"

In Blender, we used to use the term 'draw' to refer to information
displayed to the user. For version 2.80, it was decided to change these
instances to 'display' instead. This was to avoid the ambiguity between
end-user drawing tools and display options.

From the Oxford English Dictionary:
- Draw: produce (a picture or diagram) by making lines and marks on
paper with a pencil, pen, etc.
- Display: show (data or an image) on a computer, television, or
other screen.

Therefore, we should use draw when referring to drawing tools for
making marks, but use display when referring to information
shown/displayed to the user. From a user POV, the computer displays
certain information, whereas the user draws a mark.

Apparently this change was not implemented consistently, so this patch
changes all remaining relevant instances of "draw".

Differential Revision: https://developer.blender.org/D10551
Revision 6471cf6 by William Reynish / Hans Goudey (master)
March 2, 2021, 17:58 (GMT)
UI: Clean up labels and descriptions: "Draw" to "Display"

In Blender, we used to use the term 'draw' to refer to information
displayed to the user. For version 2.80, it was decided to change these
instances to 'display' instead. This was to avoid the ambiguity between
end-user drawing tools and display options.

From the Oxford English Dictionary:
- Draw: produce (a picture or diagram) by making lines and marks on
paper with a pencil, pen, etc.
- Display: show (data or an image) on a computer, television, or
other screen.

Therefore, we should use draw when referring to drawing tools for
making marks, but use display when referring to information
shown/displayed to the user. From a user POV, the computer displays
certain information, whereas the user draws a mark.

Apparently this change was not implemented consistently, so this patch
changes all remaining relevant instances of "draw".

Differential Revision: https://developer.blender.org/D10551
Revision 601b690 by William Reynish / Campbell Barton (master)
January 25, 2021, 12:46 (GMT)
Fix T84911: Add Primitive and IC keymap - 3d navigation conflict

Ref D10176
Revision da2955f by William Reynish / Campbell Barton (master)
January 25, 2021, 12:41 (GMT)
UI: improve categorization in Grease Pencil Layers sub-panels

The "Layers" panel for Grease Pencil objects uses sub-panels to organize
their properties in categories. Currently, this isn't so clear.
This patch cleans up these sub-panels with clearer categorization.

Reviewed By: #grease_pencil, antoniov, Blendify, HooglyBoogly

Ref D10184
Revision 5f2c5e5 by William Reynish / Campbell Barton (master)
January 25, 2021, 10:28 (GMT)
UI: object context menu tweaks for consistency

Currently, the object context menu includes some inconsistencies
between object types. This is a small patch that fixes these.

- Adds the same ability to Join and Set Origin
to all supported object types.
- Adds Set Active Camera for cameras.
- Adds Adjust Stroke Width for GP Objects.
- Adds Trace Image to Grease Pencil for Image Empties.

Reviewed By: #grease_pencil

Ref D10144
Revision 5f55022 by William Reynish / Campbell Barton (master)
January 25, 2021, 09:12 (GMT)
UI: tweak object context menu labels

A number of naming changes for consistency and clarity

- Use 'Adjust...' for all entries that adjust properties
rather than being normal operators.
- Follow naming conventions (ie Draw -> Display etc).
- Less naming ambiguity and more correctness and consistency.

Part of D10144
Revision 5a1cef2 by William Reynish / Campbell Barton (master)
January 25, 2021, 06:49 (GMT)
UI: move 'Trace Image to Grease Pencil' to 'Convert' sub-menu

This operator is very specific, and may not warrant being placed in
such a prominent place. Move it together with other convert operators.

Ref D10188
Revision 5254ffa by William Reynish (master)
May 25, 2020, 19:50 (GMT)
Fix T77051: IC keymap hotkey conflict in mode switching with GP object
Revision d882ec3 by William Reynish (modifier-panels-ui)
April 21, 2020, 18:50 (GMT)
Constraints UI: Add separator after the X to match modifiers

MiikaHweb - Blender Git Statistics v1.06
Tehnyt: Miika HämäläinenViimeksi p?ivitetty: 07.11.2014 14:18 MiikaH:n Sivut a.k.a. MiikaHweb | 2003-2021