Blender Git Commits

Blender Git "temp-sybren-usd-patch" branch commits.

November 26, 2019, 17:06 (GMT)
USD: replace check_is_transform_animated() with BKE_object_moves_in_time()
November 26, 2019, 17:00 (GMT)
Merge remote-tracking branch 'origin/master' into temp-sybren-usd-patch
November 26, 2019, 16:18 (GMT)
USD: typedef for std::map<short, pxr::VtIntArray>
November 26, 2019, 16:03 (GMT)
USD: use BKE_object_visibility()
November 26, 2019, 15:44 (GMT)
USD: Clarified some comments, distinguish Hydra from USDViewer
November 26, 2019, 15:43 (GMT)
USD: removed dead code
November 26, 2019, 15:42 (GMT)
USD: added TODO about checking depsgraph for time dependency
November 26, 2019, 15:36 (GMT)
USD: use `BKE_animdata_id_is_animated()`

`BKE_animdata_id_is_animated()` is now used to determine whether object data
has any animation. This also includes counting the fcurves+drivers; previously
the presense of a non-NULL AnimData pointer was enough to consider the
object data animated.
November 26, 2019, 15:32 (GMT)
Merge remote-tracking branch 'origin/master' into temp-sybren-usd-patch
November 26, 2019, 13:16 (GMT)
USD: clarification of USDAbstractWriter::is_supported()
November 26, 2019, 13:08 (GMT)
USD: 1024 ? FILE_MAX
November 26, 2019, 13:08 (GMT)
USD: iterate() ? iterate_and_write()
November 26, 2019, 13:00 (GMT)
USD: avoid term 'original' in non-CoW context

Instead of 'original object' the code now mentions 'source' or
'duplisource'.
November 26, 2019, 12:55 (GMT)
USD: renamed `prune_the_weak` ? `remove_weak_subtrees` + arguments
November 26, 2019, 12:51 (GMT)
USD: rename `link` to `dupli_object` and made variable loop-local

I added an explicit `!= nullptr` to make the formatter put the three parts
of the `for`-statement on three different lines (instead of two), which
increases readability.
November 26, 2019, 12:48 (GMT)
USD: made `bool weak_export` `const`
November 26, 2019, 12:46 (GMT)
USD: removed terminal colour codes
November 26, 2019, 12:44 (GMT)
USD: add unit test to test `HierarchyContext::operator<()`
November 26, 2019, 12:44 (GMT)
USD: nicer structure for tests/gtests/usd/CMakeLists.txt

This structure makes it easier to add new test source files, and avoids
using a temporary variable.
November 26, 2019, 12:02 (GMT)
USD: clarified ownership of objects returned by create_xxxx_writer()
By: Miika HämäläinenLast update: Nov-07-2014 14:18 MiikaHweb | 2003-2021